Some recent changes in Slack API remove the bot scope from RTM API. That basically means the for all new applications it's not possible to use the RTM API and the old ones will stop working at the end of 2020.

The 0.19.4 will use the Event API which has the drawback of being not compatible with the Express stack of Node-RED, for this reason the web hook server is running in a separate Express app on a different port (that can be configured in the connection panel).

Follow the updated instruction here to upgrade to the new connection params.